Loading... Please wait...
  • UPDATE CD´S (will be sending a backup copy, CD1 and CD2)

PCM 2.1 FIRMWARE UPDATE

£103,35 £39,26
(You save £64,10)
Quantity:

Product Description

PORSCHE PCM 2.1 UPDATE KIT
  
For the following Porsche model with PCM 2.1 navigation system older than 2006: Boxster, Cayman, 911 Carrera & 911 Targa 4, 911 Turbo, 911 GT2, 911 GT3.
 
 
PORSCHE PCM 2.1 UPDATE KIT (3 CD´S) with special instructions on how to upgrade your unit.
 
CAUTION: If your vehicle (or your current maps) is older than 2006, you will need this kit in order to make the 2015/2016 maps work in your car. Detailed instructions will be provided. We do not recommend to upgrade your firmware if your car AMPLIFIER FIRMWARE version is 16400. Not sure which software you have? It's easy to check. While the car is running, press "MAIN" and "TRIP" at the same time. A new screen will be displayed, with the rotorary knob select the option "AMPLIFIER". The version will be displayed.
 
 
When upgrading your firmware you can follow this steps: Manual
 
Disclaimer: Do this at your own risk, we are not responsible for any damage you may cause to your car.

Product Reviews

Write Review

  1. Works perfectly 5 Star Review

    Posted by on 18th Dec 2016

    Very good instructions. Works great

  2. Thank you! easy set up & installation 5 Star Review

    Posted by on 8th Mar 2016

    Couldnt find this firmware update in any other store, thank you climarepair, now I can use the 2015 maps update in my 2005 Carrera!

Quantity: